Ford C-Max Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
Hi,
Ive read plenty of posts that deal with this but i just want to confirm my problem.

I have a 2004(54) Zetec 2.0 TDCi, the car struggles when pulling away from standing start, and sometimes in 2nd and 3rd acceleration. theres plenty of power but it seems to miss a few beats, which is off putting and dangerous at roundabouts! It feels like im running out of Fuel.

Then this morning, i almost stalled on a hill start because the car was struggling to get up to 1000rpm and wouldnt go any further, once i got up the steep hill and to a safe place i turned engine off, restarted, and it revved up fine. Just still missing a few beats every now and then.

theres no excess smoke from exhaust (just the normal diesel puff when i floor it.)
Ive just had a new and fuel filter put in, didnt solve it.

I had the same problem with a petrol Fiesta, doing 70mph then slowing rapidly to 1000rpm, which turned out to be the ECU, and it seems like this is the case again after reading other posts!!

am i right?
and is the only solution to buy an ECU from a '06 onwards Cmax at a cost of over £700?

Matt
 

·
Registered
Joined
·
1,200 Posts
Now this could be a sticky EGR valve, something Ford are very well aware of.
I know the syptoms, Engine on idle and no power or your going along and you go to put the power down and the revs flux but no real pulling power.

Solution? Well you could clean it with carb cleaner but the EGR is at the back and not easy to get to (I want to clean mine as well)
Could ask a garage to clean it or Get a new one!
Last one sounds mad but I think a new one costs around £160 or less (seen on another forum) + fitting.
 
1 - 2 of 2 Posts
Top