Ford C-Max Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi, just been dropped off by the recovery man!!

08 model 1.8 Zetec, bought it on about 50 miles on the clock from a main dealer two months ago. Now on about 800 miles.

Drove for about 2 miles of a journey this evening, and suddenly the electrics just drop out - all lights go off, power steering goes sticky etc. Engine warms up a little, car travels another 100 yards then packs up completely loss of eveything and "engine failure" shows up on dash info panel. Bad burning/electric smell fills the cabin. 3 week old son removed quickly in carseat! Thankfully close to parents house so got little fella home. Recovery turns up and say "nothing we can do with that!" and deposits us home.

Contacting the main dealer in the morning, has anybody experienced anything similar, and perhaps can give any advice about what we should do / can expect?

Frankly though, I'm glad it failed tonight, and not on the way to afuneral tomorrow afternoon
!

Cheers!!!
 

·
Registered
Joined
·
315 Posts
sorry to hear of your trouble mate, av had me 1600 c max for nearly three months now , been totally perfect ..........touch wood
. Got it brand new from main dealers , a love the car. Hope you get sorted asap.
 

·
Registered
Joined
·
7,765 Posts
I was going to say "main fuse" but as the dash warning lights remained on unlikely

At present it may not seem like it but such a catescophic failure should actually be easier to finf
 
1 - 3 of 3 Posts
Top