Ford C-Max Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
A couple of days ago I was driving my 2012 1.6 Duratorq diesel down a bumby country land. No problems previously. Sudden power loss, engine running rough, review engine dialogue flashes on screen, orange engine icon comes on. Barely enough power to move.

Car limps along at 10mph, barely makes up a hill in 1st. RPM wouldn't go above 2000, without load. I pulled over started it up and same juddery engine and lack of rpm above 2000. turned off and let sit.

Half hour later restarted, same symptoms. But I did shift into reverse and pull back and forth, then shut down.

Returned half hour later, and it started, reved normally and drove as normal. Drove 50 miles without problems. Warning engine dialogue not showing then, but engine icon light still on. Made it home fine.

Next day turned on, fired up and drove normally for 50miles and now the engine icon light is gone.

So no problems now, but worried it may return. reading forums I'm wondering if a sensor got knocked when driving bumpy roads or maybe a bit of bad diesel got thrown up into filter (tank was 1/8 full) or maybe a faulty egr? Or what?

I'm assuming that with no fault lights showing any error codes that putting on diagnostic bench wouldn't pick up the historic error from 2 days ago.

I'm thinking to replace fuel filter as precaution and hope it doesn't return. But i could take down to local mechanic for diagnostics.

Thoughts? I've read some great insight from people here. I could use some.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
great, thanks for that tip. I will do.
 

·
Registered
Joined
·
31 Posts
A couple of days ago I was driving my 2012 1.6 Duratorq diesel down a bumby country land. No problems previously. Sudden power loss, engine running rough, review engine dialogue flashes on screen, orange engine icon comes on. Barely enough power to move.

Car limps along at 10mph, barely makes up a hill in 1st. RPM wouldn't go above 2000, without load. I pulled over started it up and same juddery engine and lack of rpm above 2000. turned off and let sit.

Half hour later restarted, same symptoms. But I did shift into reverse and pull back and forth, then shut down.

Returned half hour later, and it started, reved normally and drove as normal. Drove 50 miles without problems. Warning engine dialogue not showing then, but engine icon light still on. Made it home fine.

Next day turned on, fired up and drove normally for 50miles and now the engine icon light is gone.

So no problems now, but worried it may return. reading forums I'm wondering if a sensor got knocked when driving bumpy roads or maybe a bit of bad diesel got thrown up into filter (tank was 1/8 full) or maybe a faulty egr? Or what?

I'm assuming that with no fault lights showing any error codes that putting on diagnostic bench wouldn't pick up the historic error from 2 days ago.

I'm thinking to replace fuel filter as precaution and hope it doesn't return. But i could take down to local mechanic for diagnostics.

Thoughts? I've read some great insight from people here. I could use some.
Hi, Maybe there is a problem - maybe not . I'll just relate to you my experience with a 56 plate 2.0 petrol. Shortly after taking ownership in 2012, I had the situation where the car either conked out or ran very rough, the orange engine would light come on - but after a very short space of time, the car would restart , the light went out, and all was fine.
This happened maybe four or five times, over the space of two years, and then it stopped happening.
Hopefully, this will turn out to be your experience - I guess it's all part of computer enabled motoring
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
thanks for the replies. Took it in to get diagnosed on computer and mechanic said there wasn't a problem now and must have been a temporary problem that has sorted itself. All I can think is a contact became disconnected while driving down bumpy road and when I reversed and stopped later, contact became more secure. Car hasn't shown any relapse to temporary low rev symptoms and has driven normally since. I'm baffled really.
 
1 - 5 of 5 Posts
Top