Ford C-Max Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have been having a nightmare
with my c-max, garage has found error code po171 system to lean bank 1.
They have done all visual checks for leaks (exhaust & air) and replaced the lamba sensor but no good, they are talking about replacing the air flow mass meter next - has any body had this before or does anybody have any ideas about this fault.
 

·
Registered
Joined
·
1,200 Posts
Had a quick google about this and this what I found from an american site: http://www.focusfanatics.com/forum/showthread.php?t=144710

A code P0171 may mean that one or more of the following has happened:

The MAF (Mass Air Flow) Sensor is dirty or faulty. Note: The use of "oiled" air filters (K&N, etc.) can cause the MAF to become dirty if the filter is over-oiled
There could be a vacuum leak downstream of the MAF sensor.
Possible SolutionsPossible solutions include:

In the vast majority of cases, simply cleaning the MAF sensor does the trick. Consult your service manual for it's location if you need help. I find it's best to take it off and spray it with electronics cleaner or brake cleaner. Make sure you are careful not to damage the MAF sensor, and make sure it's dry before reinstalling
Inspect all vacuum and PCV hoses, replace if necessary
Check for a dirty fuel filter and proper fuel pressure
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Hi and cheers for that, air leaks have been checked and none were found, the air mass meter seems to keep cropping up, does any body know where the mass air flow meter is on a 2005 1.6 petrol c-max, i am thinking about stripping it off and trying to clean it to see if this makes any change before the garage replace it, im used to them being part of the air intake piping but someone has told me that it could be built into the throttle housing.
 
1 - 4 of 4 Posts
Top