Ford C-Max Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a 2013 Ford Grand CMax 1.6 TDi with 90,000 miles on the clock. We have owned it since it was a year old at less than 10,000 miles. Never missed a main dealer service.

10 days ago the Engine Malfunction message came up and the car went into limp mode. My code reader said that the DPF was below effectiveness, so I followed all advice about driving it at high revs for a while, and I have also changed from using diesel from Sainsburys (which I continue to use without problem on my BMW) to Shell and Esso. I have run some DPF cleaner (Wynns and Cataclean) through. No improvement, as although the message clears every time the engine is switched off and restarted, it comes up again at around 2200 revs.

So I thought that maybe it has an Eolys take which needs to be refilled, but having looked between the spare wheel and fuel tank, I don’t see one.

I have seen videos of people using a cleaning spray directly into the DFP through the sensor port. I would be willing to try similar before handing more money over to Fords, as it was only 5 weeks ago since I was charged £540 to have an injector replaced, and last year it needed the gearbox replacing. That was at 75,000 miles. As a side note, during the gearbox replacement it was remarked at the shocking rate of corrosion there was on the chassis. Not impressed at all with the quality.

Excuse my frustrated rant, but I still have the current problem to resolve, and I don’t want it to cost more than it needs to. So can anyone offer any advice on what I should try next, please?

Besides daily school runs, the car is used at least three times a week for commutes (25 miles each way) on main A roads and dual carriageways, and longer runs of 100+ miles many weekends.

Thanks.
 
1 - 1 of 1 Posts
Top