Ford C-Max Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
1.6 TDCi early 2004 model

Im having trouble with my cmax, the other day it wouldnt go past 3000 revs, with no engine management light on.
Then suddenly yesterday it started going ok, (not 100% right as i seem to have lost some power) but now the engine management light has come on.

When accelerating it seems a bit smoky (black)

Someone told me its either the MAF sensor needing cleaned or the E?? valve needs replaced.

Im going to have a go with the MAF senor first as that seems as though it wont be that difficult.

Does anyone know where is this located on the 1.6 TDCi early 2004 model?

Thanks in advance
 

·
Registered
Joined
·
7,765 Posts
Should normally be one of the first items in the inlet air tract just after the air claener

The E?? is probably the EGR or exhaust gas recirculation valve that feeds exhaust gas back round so as primarily to refuce the emissions of oxides of nitrogen that are profuced
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Richard G said:
Should normally be one of the first items in the inlet air tract just after the air claener

The E?? is probably the EGR or exhaust gas recirculation valve that feeds exhaust gas back round so as primarily to refuce the emissions of oxides of nitrogen that are profuced
Thanks for the quick reply. EGR is what i meant thanks.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Ok, cleaned the MAF sensor and took it for a spin.

No change in the black smoke coming out the back and still feels sluggish.

Do you think its worth while changing the EGR valve? If so, is it a job that a DIY mechanic could do on his own?Edited by: Angus
 

·
Registered
Joined
·
7,765 Posts
I think a check of the fault codes is the first step

The EGR problem was mostly with the 2.0L not the 1.6 though there were some
 
1 - 5 of 5 Posts
Top