Ford C-Max Forum banner

41 - 60 of 61 Posts

·
Registered
Joined
·
6 Posts
Mine stopped working around June 2014. Just said 'no service' on any present. Kept checking about twice a month, same thing. December 2014 tried it and it worked like normal.

The only thing that may have caused it to happen in the first place (but shouldn't) was loads of using the search button as I was on a good few hundred mile drive at the time and kept changing stations.

Didn't bother going to Ford I'm not under warranty but at least after a 6 month rest, it started working!
 

·
Registered
Joined
·
1 Posts
Hi, mine has done the same, it says no service. I have the same question as mattmk6, did ford pick up the bill for this seen as it is a known problem?
 

·
Registered
Joined
·
1 Posts
This might help

take the Ariel off , spray a small amount of WD40 in the hole and re screw in tight . re tune/scan the DAB unit but you have to save every station you want as you go , they have all been forgotten ... this worked for mine , 2012 titanium , with Sony unit .
 

·
Registered
Joined
·
31 Posts
Hi. My DAB has died tonight... only owned the car for a week. A 2011 cmax titanium with comfort and family packs.
The DAB was always 'dodgy' as in it would display 'no reception' most of the time even though the radio was playing OK. And It struggled to receive some stations I would expect to be better.
However it's now gone altogether. When I select DAB1 it will show a spinning symbol before going to preset 7 KISSTORY and no sound is produced. The presets do not react to any presses and if I try to jump to DAB2 it shows the spinning symbol again before returning to preset 7 on DAB1 again.
I hope this doesn't require a new radio after a week of ownership. I appreciate it's 5 years old but still can't be bothered with the probable battle with ford's over it.
It's under a 3 month warranty from the MINI dealers I bought it from but I bet the stereo isn't covered.
Did everyone require new stereo's???

Sent from my GT-I9505 using Tapatalk
 

·
Registered
Joined
·
31 Posts
Anyone??? I'm contacting the dealer I purchased it from today to see if they're willing to do anything. The warranty doesn't cover it. Since I only bought it 2 weeks ago I'm sure I'm covered by consumer protection??

Sent from my GT-I9505 using Tapatalk
 

·
Registered
Joined
·
6 Posts
Mine Has Never Worked !

I have had a 2011 1.6 Petrol Titanium for about a month now and mine has never worked. Every time I go to DAB1 or DAB2 I get the hourglass and "No Reception". FM and every other function work fine.

This is such a common issue. Ford should be doing something about this regardless of whether in/out of warranty.

I have not approached the dealer I got it from either. Their 3 month warranty does not cover it either. Might try Ford for a laugh.
 

·
Registered
Joined
·
3 Posts
Hi. My DAB has died tonight... only owned the car for a week. A 2011 cmax titanium with comfort and family packs.
The DAB was always 'dodgy' as in it would display 'no reception' most of the time even though the radio was playing OK. And It struggled to receive some stations I would expect to be better.
However it's now gone altogether. When I select DAB1 it will show a spinning symbol before going to preset 7 KISSTORY and no sound is produced. The presets do not react to any presses and if I try to jump to DAB2 it shows the spinning symbol again before returning to preset 7 on DAB1 again.
I hope this doesn't require a new radio after a week of ownership. I appreciate it's 5 years old but still can't be bothered with the probable battle with ford's over it.
It's under a 3 month warranty from the MINI dealers I bought it from but I bet the stereo isn't covered.
Did everyone require new stereo's???

Sent from my GT-I9505 using Tapatalk
This is exactly the same issue as I occasionally experience (also a 2011, but Titanium). The issue eventually clears, but it has repeated itself a number of times during my ownership period.

I have a feeling that dis/re-connecting the battery may be successful, but I have been too lazy to try!

You can enable the service link and listen to a station that broadcasts on both services (e.g. BBC Radio) and it will automatically switch back when the error clears (the display may show "FM+", just beneath the function icon, on the left).

Sorry that I'm not able to provide a solution!
 

·
Registered
Joined
·
31 Posts
Mine is a Titanium also Tatty42. My battery was replaced yesterday as that died too. (Eventful 1st week of ownership). And the Dab issue is still there except now it just sits there displaying "no reception". The scan and preset buttons do nothing.
I rang local Ford dealers who said the service team will need to look at it but it may just need the Dab module resetting. I'm not confident. I'll be speaking to the dealer I purchased it from on Monday to try and get somewhere. And get the £55 back off them it cost me to get a mobile mechanic to replace the battery for me yesterday.

Sent from my GT-I9505 using Tapatalk
 

·
Registered
Joined
·
1,060 Posts
There are a couple of fuses in the fuse box under the glovebox that are relevant. Pull them for 30 seconds to see if it resets. It worked for me in the past. Sorry I don't know exactly which fuses.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
31 Posts
One ford dealer want it for 30 mins to diagnose at £37 and another wants it for an hour to do a software update at £70.
The dealer I bought it from said "we'll probably pay for the diagnosis but don't let them do anything else to it".
Ford can't believe I am having to sort it after only owning it for 2 weeks. The dealer I bough it from is a BMW and Mini main dealers and it was a trade in.

Sent from my GT-I9505 using Tapatalk
 

·
Registered
Joined
·
31 Posts
The dealers i purchased from have agreed to pay for a diagnosis/software update at a main dealers. Been quoted £70 so need to book it in tomorrow.

Sent from my GT-I9505 using Tapatalk
 

·
Registered
Joined
·
106 Posts
Can you get various DAB ensembles to display? I'm still struggling to come to terms with the way that DAB works on the Sony stereos in Fords. Some months ago when I went to drive home from work, I had no radio at all, just loud interference noise. When I stopped to fill up with fuel and re-started the engine, magically everything was OK again.
A week or two before Easter I had a load on roof bars that moved and sheared off the aerial complete with threaded insert into the base, and despite no aerial, I still had FM and DAB reception. I've sorted that out now with a new second-hand replacement and still (fingers crossed) have FM and DAB reception that's OK, but the whole way that the DAB works is very confusing and not intuitive at all, as it seems when you have stored stations as pre-sets, it keeps them in the same ensemble. So if all your presets had been saved, for instance in a South Wales ensemble and you live in Scotland, then none of them would work and you'd have to re-tune everything in from scratch.... at least that's how it appears to me.

Fingers crossed that you get a speedy and cost-free solution
 

·
Registered
Joined
·
31 Posts
No ChrisM i dont get anything. Just as description. A spinning symbol then nowt. Its booked it at ford this Friday so I'll post any findings....

Sent from my GT-I9505 using Tapatalk
 

·
Registered
Joined
·
31 Posts
So just heard from the ford dealers where its been all day. The software updates took 3.5hrs to complete.!!
Anyway they didnt resolve the dab issue and he says its either a break in a cable between the radio and antenna or antenna and antenna base? So now its back to the dealers i purchased it from for them to arrange it with ford.

Sent from my GT-I9505 using Tapatalk
 

·
Registered
Joined
·
31 Posts
They've agreed to get it sorted and just have ford invoice them
So its booked in for 2 days next month to bottom it out once and for all. Hopefully.

Sent from my GT-I9505 using Tapatalk
 

·
Registered
Joined
·
2 Posts
Right, has same problem, DAB radio just suddenly stops working. Went to Ford dealership, they want charge me £300 just for diagnostic ...

After couple of days found a used radio unit on eBay ... got us for £40 ... instal it by myself ... now my DAB working again...
Looks like it's a problem with dab module inside the radio unit ...
 

·
Registered
Joined
·
5 Posts
It's a very small consolation to see all Ford C Max radio's are giving the very same problem as mine...I've never come across such a load of rubbish in all my life of motoring, and it's a tiny periscope viewing of the info too.... what a let down after the superb radio I had in my Nissan....Ford you have a lot to learn !! a long journey in the C Max is terrible and the radio cannot hold stations it had been preset to just a few days ago ...... a real let down !!!!
 

·
Registered
Joined
·
1 Posts
I have a 2014 ford cmax fitted with DAB but no option to scan or reset any idea how to go around this to scan because I only pick up 1 Station
 
41 - 60 of 61 Posts
Top