Ford C-Max Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi,

I'm new to this Forum. Have had my 54 reg 1.6 tdci ghia c-max for two months now.

About a month ago I started to get the Limited EPB function warning message appear. Its intermittent- sometimes its on, other times its not. The lights on the dash keep coming and going too - the parking brake light and ABS light.

Took it back to garage yesterday (it has three months warrenty - runs out end of Aug) and they couldn't find anything wrong. Typically, warning was not showing. They've referred to Ford though.

But now... just last night after leaving the garage, the engine warning light started showing. And as I got to work this morning, the parking brake would not apply - I had to delve into the central unit and pull the override thing.

Any advice as to what I do next?

Thanks.
 

·
Registered
Joined
·
1,200 Posts
Could be the EPB unit or as Richard syas the first signs of the alternator giving up.

Just a quick to say that whatever it is, make sure you get the warrenty extended!Edited by: lawe
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Thanks for your replies.

One question about the warrenty - are they obliged to extend it? If I ask, should they? Warrenty ends at the end of Aug - it only came with 3 months, though I had the option to purchase extended warrenty.
 

·
Registered
Joined
·
7,765 Posts
there may be terms in the warranty itself about extending it.
they probably will. It will just depend what price they want to charge to do so and what terms and conditions they put in it (see my original about engine parts cover)

Get them to detail the exemptions and conditions to what is covered
 

·
Registered
Joined
·
12 Posts
i used to get the exact same thing, and yesterday I had a new alternator fitted, these seem to be classic signs of an alternator giving up, mine went at 29k miles!
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
How much does a new alternator cost?

I've had my car in to Ford (under warrenty) and they did something with the error codes etc. I haven't actually got the full details of what they've done. Guess I need to get that? The cas has been fine since but I am concerned.

My sale warrenty ends at the end of Aug and I'm worried that sometimein the not too distant future I may need a new alternator. Its at c 24k miles at the moment.
 

·
Registered
Joined
·
41 Posts
I had maybe the same problem about 4-5 months ago. Took it into Ford as i was also there for the mot and they said it was a sensor that had gone? £35 + vat which was a bit of a result coming out of the main dealer with a bill as small as that!
 
1 - 16 of 16 Posts
Top