Ford C-Max Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
i have had my 2 ltr tdci 54 plate ghia for 4 months so far it has gone in for repair as the battery light came on along with limited epb functionand then would not start so called thr rac and they said it was the alternator so he put a new battery on and followed me to the garage after putting it on a machine dealer said the programe needed upgrading which they done its been 3 weeks now and suprise suprise its happend again so could someone help with what it is so i can go to the dealer with some ideas

thanks bundiboy
 

·
Registered
Joined
·
3 Posts
I also have this problem, only difference is that I was stuck in a traffic jam in the pouring rain for about an hour. The Limited (!) EPB Function warning came on. I got the car home and left over night, when I turned the car on this morning the same warning came on then power assist warning came on and also system failure!!!!!!!!!
Ive put the battery on a slow charge to get some power back then drive it around for a while then hopefully it should dry out. Would this be wright or has my altenator packed in?
Could it have been the heavy rain affecting the charge ( it was really heavy over here in Ireland) ? I have not got a clue about cars! You put petrol in and it goes! Thats all i Know about them!!!!!!
 

·
Registered
Joined
·
1 Posts
Hi , ihad same prob two weeks ago .only difference was i was in a car park on the swiss boarder .ahhhhhhhhhhhhhhhhh . had it towed to a ford garage ,after hooking up to the computer it needed a new alternator. touch wood its been ok since
 

·
Registered
Joined
·
2,402 Posts
Once the atl starts to give less charge,it very soon packs up and need replacing,putting the battery on slow charge will help,but in the end a new alt is the only option.If when you have a new alt you still get computer warning ,get garage to reset it on diagnostics.If done at Ford dealer,they should do it as a matter of course!
 

·
Registered
Joined
·
3 Posts
Well the outcome of my woes is that I need a new altenator costing £250 for supply and fitting. Hopefully this sorts out my problem and enlighten's all concerned...
 

·
Registered
Joined
·
3 Posts
Discussion Starter #9
just to let you all know ive now got my 2ltr tdci ghia back from a very helpfull ford dealer in thrapston northants where i bought my car from. due to limited epb on the display on the dash they have now replaced the alternator and the problem seems to have been fixed.luckly when i got the car the dealer included a very good warrenty which covered the cost.however the warrenty does not include dianostic but as i got the car from them the also waved that cost so the total to me was zero.so thumbs up to thrapston fords
 

·
Registered
Joined
·
1 Posts
Hi, I think my 2.0 TDCi Ghia seems to have developed the same fault as yours! The battery charge light and epb function light have both come on, is that what happened to yours? I'm not under warrenty, mores the pity! so will have to do it my self. Just don't want to splash out on a new alternator if i don't need to.
Cheers for any help you can give me.
 

·
Registered
Joined
·
5 Posts
Hi, my '04 1.6 TDCI did exactly the same a month ago, it's only got 32000mls on the clock!!Took to my local garage how suggested alternator, so, glad I took out a warranty, it went back to Ford and yes it was the alternator!! We had it done on the warranty otherwise it's a large bill!
 

·
Registered
Joined
·
5 Posts
Mine just developed same problem (55 Ghia 1.8TDCI with 40K)...

Its in the garage at the moment...when it all stared it was accompanied by a slight change in underbonnet noise (whining noise)...my guess is it will have a new alternaotor fitted!
 
1 - 13 of 13 Posts
Top