Ford C-Max Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi I have a 1.6TDCI 2004,love the car but having problems with power loss and eratic idling.Have tried replacing the Mass air regulator which seemed to work for awhile but problem has returned.In desperation I have disconnected the mass air regulator and the is running great, apart from the engine management light is on.

Anyone got any suggestions
 

·
Registered
Joined
·
7,765 Posts
Two thoughts
first - I didn't think fuel injection engines should actually run without a voltage from the air flow meter sensor
second - this does seem to compare reasonably with where everyone seems to blame the EGR valve but that when changed makes no apparent difference

A Coincidence ?
 

·
Registered
Joined
·
125 Posts
I think it says on Honest John that early 1.6TDCi engines had problems with the intercooler pipe weld splitting, which also causes loss of power.

Have a look at the C-Max under the car-by-car breakdown.
 

·
Registered
Joined
·
8 Posts
Did you manage to sort out your power problem. I have an 04 as well and twice on long trips I have lost power and not been able to get over 3000 rpm. It does seem to reset after being turned off for 5 mins.
Jack
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
I,ve just got the car back and it is running alot smoother and cleaner than it has done for along time.The air mass regulator has been relaced,although just cleaning it will probably solve most problems,mine was soaked with oil.
 
1 - 8 of 8 Posts
Top