Ford C-Max Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi there
I have just purchased a C Max 1.6 tdci ghia on a 56 plate. It is a big step up from the Megane scenic which caused me so much hassle since I bought it new in 05. Anyway,I am very pleased with the car, in fact my kids and I love it! ( so many shiny buttons lol )

Am going to change the fake wood trim on the interior for the zetec type silver but that aside, I have noticed quite a bit of wind noise coming from the top of the front electric windows whilst driving over 40 mph. Its not leaking and I can feel no draught. I just wondered if this is a design issue or should I get it back to Ford for a check out under warranty?

Any of you guys and gals noticed same prob?

Cheers
Apple pie
x
 

·
Registered
Joined
·
280 Posts
I'd take it back and get them to have a listen.

I have an 06 Ghia and I don't wind noise even at 70mph.

I know it down to personal preference, but I actually quite like the 'fake' wood effect, at least it doesn't look really cheap like some cars i've driven where the wood effect has the look and feel of a off-cut piece of pine...


Anyway let us all know what you find the wind noise to be and welcome to the site.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
thank you. I will def take it back so they can have a listen. Mostly the stereo drowns it out but still, it does niggle me.
You have elc parking brake? If so any issues with it?

I've just read a few posts about not getting one. Bit late for that tho really!!
 

·
Registered
Joined
·
280 Posts
i do have the EPB and its okay. I would personally prefer a manual hand brake but hey, you can't have everything...


I have had a couple of issues with it where I have had a msg come up on the dash saying 'limited EPB' or something, both times it got fixed under warrenty so I have no idea what the problems were.


Apart from that, I've done about 35K miles in just over two years and it hasn't let me down yet.

I hope you get the noise sorted.
 

·
Registered
Joined
·
7,765 Posts
usually the first step when you get the limited EPB function is check battery voltage or usually check the functioning of the alternator
 
1 - 5 of 5 Posts
Top