Ford C-Max Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I was driving to the train station this morning and all of a sudden I had the red light warning flash on saying power steering failure, then 5 secs later the lights had failed and the warning message read Engine failure! <?: prefix = v ns = "urn:schemas-microsoft-com:vml" /></v:stroke></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:ulas></v:path><?: prefix = o ns = "urn:schemas-microsoft-com:eek:ffice:eek:ffice" /><o:lock aspectratio="t" v:ext="edit"></o:lock></v:shape></v:></v:shape>i was parked at this time and tried to turn the engine over, it turns over then a electrical type cracking noise to no avail, lights work everything else seems to work? any ideas on what this is how I can fix it.

thanks in advance

02 plate - 43k on the clock FSH 1.8 ghia
 

·
Registered
Joined
·
7,765 Posts
As the lights worked and it turned over then there was some power to everything

I think the next place to look may be the alternator as incorrect battery voltage does very odd things to a lot of other parts

Is it diesel or petrol and manual or auto please?
 

·
Registered
Joined
·
2,402 Posts
Sounds very like alternator failure,pretty bad one at that.Was it the original? Did you have all lights inc front & rear fogs on at time? My atl failed as as result of having both front & rear fogs on at the same time,it was the oringinal alt & had done 68000 in 4 years (not by me).
 
1 - 6 of 6 Posts
Top