Ford C-Max Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have been running a 1.6 petrol focus c-max now for 3 months, the car has done 25000 miles and has been brilliant but today whilst driving completely out of the blue the engine started hesitating and holding back, i stopped when i got home left it for a while and started it up again or at least tried to, it now starts and then stalls straight away unless you rev it as soon as it starts then it seems to miss and makes a pop sound as if overfuelling or backfiring orsomething, revs dive low after revving then pick themselves back up and will then idle fine but still feels sluggish when accelerating. the engine management light goes off as normal and doesnt come. I have seen lots of posts about egr valves but all for diesels, is this a problem with petrol models too??
 

·
Registered
Joined
·
7,765 Posts
If it idles smoothly then it is unlikely to be the EGR valve sticking open though petrol engines are likely to have them as well as diesels
As with my previous Cavalier where this did happen the idle felt very rough, almost like running on only 3 cylinders
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I have now found out from ford that this model (1.6) does not have an egr valve fitted, have tried a different coil pack and leads, these have made no difference either. I have driven the car today and it only seems to be playing up when first started, the popping and that has stopped and if you rev it a couple of times it seems to level the idle out although still a little rough, but when actually driving the car it seems completely fine, i tried driving it slowly, normally and a bit harder than usual - nothing happened ran perfect. But the stop the engine and start it again and the problem seems to re-appear.
 
1 - 3 of 3 Posts
Top