Ford C-Max Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi
I am hoping someone can give me some advice with the following problem.
Ihave a 53 plate c-max zetec. It has a tendency to stall quite easily. When the car is idling at traffic lights the revs will quite often drop to 0.5, the car shudders and there is no power when the accelerate is pressed, the engine does not cut out however. As soon as the revs go back up to 1 the power returns. The engine management light has come on several times and in all cases it has detected a fault with the engine coil. This has been replaced but the problem still remains. Quite often when slowing down the battery light will show up on the dash as if it were about to stall.
Any ideas would be most welcome!!
 

·
Registered
Joined
·
615 Posts
I used to have a escort that did that and the alternater had gone. I dont know if that is your problem but I had the same symptoms and that was mine.

Welcome to the club
 

·
Registered
Joined
·
7,765 Posts
On our previous 1.8 Focus the electronic speedo sensor was considered a problem as it inter=related with the fueling and was suspected of causing problems with stalling

A health check at the same time thought to have found problems with a failing battery but it did continue after having changed the battery

With ABS the speedo drive for the Max is taken fron one (or more wheels)

Given the number of alternator faults that have been reported on here I thick I'd check both this and the battery both hot and cold
 
1 - 4 of 4 Posts
Top