Ford C-Max Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
hi,i'm a newbie looking for an answer to my very annoying embarassing problem, every couple of weeks my 04 2.0 litre diesel zetec model cmax (130bhp) starts up and then revs hard up and down kicking out masses of thick black smoke,this is a frightening experience and people passing by ask if i'm ok? if i turn off the engine and try again its usually ok but more recently remains the same,if i rev slightly it seems to control the problem and the revs drop,tho remaining high then levelling out to a normal tickover. i've since noticed the coil/glow plug light on the dashboard remains on when all the others go out,i then know i'm in for my frightening experience again, HELP this has happened 5 times in the last week! its been in the garage with no fault found...again. i've read some of the forum and the egr seems to be a problem,could this be my culprit? any help is most welcome,thankyou.
 

·
Registered
Joined
·
336 Posts
hmmcould be the egr giving this problemit does give loads of similar symptoms ie bad starting but usually not high revs. Unexplained high revs with black smoke could be turbo/ oil seal probs suprised the garage couldnt find problems does it happen regularly?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
yes its happening on a more regular basis now, its booked in to a ford dealership on wednesday,should be interesting,thanks for your comments.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
the computer said the egr was frozen so was changed at a cost of over
£300 the next day it was the same!!!!!!! that very same day gk ford fitted a temperature censor and only charged me for the part (£25) its been ok since. (a week)
 
1 - 5 of 5 Posts
Top