Ford C-Max Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
132 Posts
Discussion Starter #1
Has anyone coasted whilst not in gear? When I coast in gear with clutch in the idle drops to about 1200, until I come to a complete stop, then it drops to a normal tick over at about 750. When I coast in neutral, clutch up, not in gear the rev jump from 750 to 1200 until the car comes to a complete stop. I have rev hang on startup between gear changes at about 2000 - 3000 rpm unil th engine is warm also have poor mpg, could it be linked?
 

·
Registered
Joined
·
7,765 Posts
Anywhere in particular do you know?
Not really but it ought to be engine side of the throttle plate ~ you might like to try flexing various bits and see if it makes any difference to idle speed
Is it a case of a split pipe etc?
Could be but then again may not. It might also be a temperature sensor giving too much fuel as though engine were still slightly cold
Can an air leak cause bad mpg?
If the revs don't drop back as fast as they should then you are using extra fuel so very likely do affect MPG
Have you checked that there are no fault codes showing?



 

·
Registered
Joined
·
132 Posts
Discussion Starter #5
Have you checked that there are no fault codes showing?
Checked codes and there is nothing stored. The scanner does live data but I don't know what it should read. Long term and short term fuel trim change all the time, as does spark advance. Does no one know what the readings should be?
 

·
Registered
Joined
·
161 Posts
Just to confirm, I coasted downhill and my revs dropped to the normal idle point ~750 RPM - in & out of gear with or without the clutch engaged.

Have you ever had the engine management software upgraded, there were a lot of tweaks which have improved my car.
 

·
Registered
Joined
·
28 Posts
it is probably totally irrelevant, but exactly the same thing happens in my lotus elise e.g. if I coast up to a red traffic light
 

·
Registered
Joined
·
77 Posts
@Dave467

I have recently took the inlet manifold off and gave it good clean + the same on throttle body.
I have put everything back together and my car started to suffer from the same symptoms :(
When cold it suffers from throttle hang at about 1500-2000 rpm.
It stops after 2 minutes and everything goes to normal.

I have not noticed any worsening in mpg for now however. Still getting 31-32 mpg in town.

The first thing i will double check and suggest for you to do the same is to have a look (easier said than done:) at the PCV to inlet manifold hose.
Apparently that tends to split sometimes causing similar effects although when that happens people seem to experience throttle hang at higher revs > 3000 rpms and it does not stop when engine warm.

Maybe that is something else then...

@ jimblob2

what software upgrades?:)

are they free from Fraud?

when did you do yours?

what improvements are we talking here?
 

·
Registered
Joined
·
132 Posts
Discussion Starter #9
@Dave467

I have recently took the inlet manifold off and gave it good clean + the same on throttle body.
I have put everything back together and my car started to suffer from the same symptoms :(
When cold it suffers from throttle hang at about 1500-2000 rpm.
It stops after 2 minutes and everything goes to normal.

I have not noticed any worsening in mpg for now however. Still getting 31-32 mpg in town.

The first thing i will double check and suggest for you to do the same is to have a look (easier said than done:) at the PCV to inlet manifold hose.
Apparently that tends to split sometimes causing similar effects although when that happens people seem to experience throttle hang at higher revs > 3000 rpms and it does not stop when engine warm.

Maybe that is something else then...

@ jimblob2

what software upgrades?:)

are they free from Fraud?

when did you do yours?

what improvements are we talking here?
My problems started after cleaning the throttle body. I replaced the throttle body with one from a breakers yard and although the problems improved slightly they are still there. previously the revs climbed when dipping the clutch now they just hang.

fuel consumption is bad, only getting 300 miles out a tank. I may have other issues around the fuel consumption though as it seems I may only have a 10 gallon tank. I can only ever fit in about 10 gallons, I thought it may be that the trip computer thought it was empty when it wasnt but when the trip computer said something like 3 miles left I could here the fuel pump and I got a misfire.
 

·
Registered
Joined
·
161 Posts
The software upgrades are not free, I was getting powertrain lights coming on and a lack of power - cost £80 to run a diag and update the software. Things I noticed after the update;
1. The accelerator pedal no longer touch sensitive - was jerking when pulling off and you only had to feather touch the pedal and it would rev.
2. A more smoother power output with no 2000 rpm glitch, go over 3500 rpm and the car flies (VVT cuts in)
3. Better fuel economy by about 5 MPG
4. When in traffic the aircon does not come on as often so improved economy from that although a bit annoying when you want to get the car cold in traffic.
5. Improved driving with aircon switched on, it would sap the power but now drives great with the aircon on
6. EGR cleaning cycle - every now and then the PCM will cycle the EGR valve after the engine is switched off to stop it sticking.

I did mine shortly after having the car because the power train light kept coming on and I was having lots of running issues which the previous owner did not tell me about.
 

·
Registered
Joined
·
3 Posts
Is this thread still active? I have the same issue with my cmax. Just changed plugs oil and filters but still there. Only when coasting in neutral.
 
1 - 13 of 13 Posts
Top