Ford C-Max Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
406 Posts
Yes I've changed my STOP+Tail bulbs to LED work OK
BUT..when I changed my Front and rear Indicator bulbs I just got HYPERFLASHING (TOO FAST TO BE LEGAL) with or without Resistors inplace.So I put my indicators back to original tungsten bulbs :(
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #3 ·
Yes I've changed my STOP+Tail bulbs to LED work OK
BUT..when I changed my Front and rear Indicator bulbs I just got HYPERFLASHING (TOO FAST TO BE LEGAL) with or without Resistors inplace.So I put my indicators back to original tungsten bulbs :(
You got any links for the bulbs?
 

·
Registered
Joined
·
470 Posts
Trouble is the later c max indicators are monitored by a module and if the wattage drops as it does when you fit leds it's the drop in wattage the module picks up and it assumes you have a bulb out and so does a rapid flash to warn you.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #5 ·
Trouble is the later c max indicators are monitored by a module and if the wattage drops as it does when you fit leds it's the drop in wattage the module picks up and it assumes you have a bulb out and so does a rapid flash to warn you.
Are right . So it might not be the best thing to do on me 2011 model .
 

·
Registered
Joined
·
406 Posts
Leeappleby.....E/Bay....Bang in Argo City Ltd.....
Don't forget to checkout the pin set up on your old bulb eg offset/equal opp or
each pins figuration has it's own number.
 

Attachments

1 - 6 of 6 Posts
Top