Ford C-Max Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
I was driving along the other day when the battery light came on. Pulled over to check under the bonnet checked the belts etc and all was OK. I checked the voltage and noticed it was not charging. When I set of againI noticed an unusual whine. I suspect coming from the alternator. <?: prefix = o ns = "urn:schemas-microsoft-com:eek:ffice:eek:ffice" />

Howevera bit later the battery light went off and it had started charging again.

I have noticed on other forums that this seems a common intermittent problem with the alternator.

Does anybody have any experience of this and how long the alternator last before completely breaking? I have heard that the alternator can also break with the alternator trying to charge the battery all the time even when it is full which damages the battery.

I have booked it into the garage but the early they can see it is next Tuesday and I need to drive 500 miles before then.

It seems to be working OK at the moment. :-O
 

·
Registered
Joined
·
2,402 Posts
Shouldn`t damage battery.best to charge it up each noght till alt replaced,just to make sure you have a full charge.I have no clues as to life of alt,as I got my C-Max as used,but it did need replacing very soon after purchase.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #3
The car did last the 500 miles. The alternator wasn't charging for the first 3 mins of every journey and it was making the whining noisebut after the 3 minsit was OK. I have had it replaced now and it seems OK, first proper journey tomorrow though. <?: prefix = o ns = "urn:schemas-microsoft-com:eek:ffice:eek:ffice" />
I also had the belt changed, the fuel filter since it is due shortly in the next service and I have no idea how to bleed it. The garage also picked up on that fact it needs a new wheels because one was buckled and I also had 4 new tyres. Total Bill was £800!! Ops!!!
 
1 - 4 of 4 Posts
Top