Ford C-Max Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi

I have a Ford C-Max 12 plate

My car alarm went off but the car lights were not flashing. I was unable to disable the alarm with any of the keys and could not unlock the car. I used the manual key to get into the car but was unable to start it. None of the electrics work in the car ie radio, lights etc


Has anyone experienced this before or know what the issue is?

Thanks
 

·
Registered
Joined
·
746 Posts
Hi

Hi,
don't have a definitive answer, but sounds like something has upset the immobiliser.
l would check the battery terminals and voltage and check the interior ecu for water ingress or loose connections.
Good luck
Bob.
ps let us know what it was when you find it please.
 

·
Registered
Joined
·
5 Posts
Hi

I have a Ford C-Max 12 plate

My car alarm went off but the car lights were not flashing. I was unable to disable the alarm with any of the keys and could not unlock the car. I used the manual key to get into the car but was unable to start it. None of the electrics work in the car ie radio, lights etc


Has anyone experienced this before or know what the issue is?

Thanks
Thanks Mohd. Did you manage to get this resolved? Have the same issue with my Grand C-Max this morning. Woken with alarm going off +but no flashing lights), door key would not open car so had to manually open,no lights or electrics worked inside. Car would not make any noises when trying to start when pressing start button. Tried the key insertion method by the steering wheel and nothing. Just get the flashing red information (I) light with no information message. Tried disconnecting battery and leaving for 15 mins and nothing. Any guidance greatly appreciated. Paul
 
1 - 3 of 3 Posts
Top