Ford C-Max Forum banner
1 - 6 of 6 Posts

Registered
Joined
3 Posts
Discussion Starter · #1 ·
Hi my name is Darren nice to meet any of you who reads this. Basically I've had a headache with this car was hoping may be some who have had similiar issues and have any tips.

Backstory....

Cluster instrument panel causing low acceleration and engine faults intermittent. Took it out reflowed solder somewhat resolved them issues.

Now turbo blew. I cleaned all pipes out cleaned intercooler out fitted new oil pipe and turbo. New oil new air filter new oil filter.

On the turbo breaking rac flagged up multiple codes...

MAF sensor in range but low
Fuel pressure rail low
Egr valve frozen
Fuel running lean

Symptoms I'm getting is dodgy idle.....doesn't accelerate properly.....sounds bad and no power......

So far I've changed fuel filter and cleaned the top part of the egr as struggled to get it out to no change.

Two errors I'm getting up still see fuel bank 1 lean and fuel rail low pressure

I'm awaiting delivery of a new MAF sensor.

I've got a video and done some charts unsure if I can attach these but could send to anyone whos good with these If helps any help be grateful.

Darren

Dunno if any of these graphs will show anything

Rectangle Slope Font Line Parallel
Rectangle Font Slope Line Parallel
Rectangle Slope Font Line Parallel
Rectangle Slope Font Parallel Pattern
Rectangle Font Parallel Screenshot Number
Font Screenshot Number Magenta
 

Attachments

Registered
Joined
498 Posts
If turbo blew did you remove the sump and check for debris and oil pick up gauze for debris? a must or this could cause further problems with oil restriction.
Did you clean the MAF sensors there's two of them? must be doe with the correct MAF
Food Font Drink Liquid Material property
cleaning fluid only.
Reset codes or disconnect battery for half an hour fingers crossed may cure some of your problems may be all.
 

Registered
Joined
3 Posts
Discussion Starter · #3 ·
Sorry I changed the sump ....and sprayed some at the oil pickup....wasn't really no bits I could see in the pan....couldn't get the pickup out one bolt was totally rounded tried everything .....

Didn't know there was 2 mafs........

1.6 tdci 2008 cmax
 

Registered
Joined
7 Posts
Fuel error might pop-up because of fuel pomp wear. Thats common problem in many Ford models. It is not explaining rest of your codes anyway. MAF can be oiled and EGR clogged as well-but these 3 faults in this same time seems to be a bit strange.
Perhaps ECU was damaged during this "soldering" repair you wrote about? Did you disconnected battery before you started it?
 

Registered
Joined
3 Posts
Discussion Starter · #5 ·
Fuel error might pop-up because of fuel pomp wear. Thats common problem in many Ford models. It is not explaining rest of your codes anyway. MAF can be oiled and EGR clogged as well-but these 3 faults in this same time seems to be a bit strange.
Perhaps ECU was damaged during this "soldering" repair you wrote about? Did you disconnected battery before you started it?
The instrument panel was removed and reflowed the solder common ford problem cold joints ?
 

Registered
Joined
7 Posts
If you removed it for repair, and you didn't shortcuts anything during this process, it won't damage ecu I think. Sorry, have no more ideas. On your place, first I would ask somebody with pressure gauge, to check how much pressure your petrol pump giving. It's a simply and quick job- just disconnecting one hose under bonnet and plug in gauge.
If pressure refer to factory one- more likely ecu gets errors from bad connectors (mostly because of moisture) or is just broken and you need a new one.
If pressure is low-thats mean your ecu us right and you have to change petrol pump, clean maf sensor and fix egr :D

Last what I realised just now- consider how old is your battery.
Sometimes, when is old, voltage when you're starting engine is going under 11V and in this point ecu is going crazy. It may cause errors and than system is using referral values instead sensor ones- what causing engine works poor.
But that's a veeeeeery long shot :D
 
1 - 6 of 6 Posts
Top