Ford C-Max Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
It has been really hot over the last few days. My A/C doesn't seem to be blowing ice cold air like it had been last year. I did run it now again to keep it from seizing up.
Any ideas what the problem can be?


2004 1.6 Zetec Tcdi

Thanks
 

·
Registered
Joined
·
336 Posts
Possibly a leak over winter or stone damage to the ac rad. Today i put mine on recirc as well to get it ice cold. Temp on instruments was 85 so i`ll let it off.
 

·
Registered
Joined
·
8 Posts
Defiantly sounds like the coolant has run dry. Could you hear a gurgling sound the first time you usedthe A/Cand it didn't work properly? I ask because Ihad a Suzuki Cappuccino which needed charging every 12-18 months, there was a leak in the system but I never found it or too bothered as when the sun came out the roof came off! Anyway the gurgle was the sign that the A/C was just about empty. <?: prefix = o ns = "urn:schemas-microsoft-com:eek:ffice:eek:ffice" />

Not sure if this helps any?
 

·
Registered
Joined
·
1,200 Posts
When you switch the AC button on, does the compressor start? or do you notice a slight drop in revs?

If Yes to both, the sounds like you need a recharge. My other car was in the same boat and I found a mobile independent air con chap who did the whole job properly for £45 and it is now perfect.
It's a full suction of the whole system, which removes any water in the system and also sees if the system holds the vacuum. He then adds the oil and follows this with the correct weight of gas. Job done in about 30 minutes.
Will be doing the cmax next, just to keep her in tip top form.
 
1 - 5 of 5 Posts
Top