Ford C-Max Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi folk's advice needed re an issue with my vehicle,last friday I was about to drive to work and
got an engine malfunction warning light and triangle.Called the RAC and the fault was detected
with the egr. to be exact......
Particulate trap below efficiency threshold bank one.
egr system fault
fuel additive control module mill request
my garage are great but due to work they are situated 13 miles away next to my depot.
the RAC guy said no way drive there so it's gone to a local garage over the road.
long story short the cars not even been looked at since Saturday I'm a food delivery
driver who's spent the week inconveniencing colleagues for lifts and my patience is worn out
with the prospect of no fix it date,can the car be driven to my garage of choice safely as I need
this issue sorting? the car seemed to drive fine.
 

·
Registered
Joined
·
489 Posts
hi steve, if you drive the vehicle you risk blocking up the DPF which can cause further issues. it sounds like the fuel additive needs refilling and resetting. shouldnt take more than an hour to do.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
hi steve, if you drive the vehicle you risk blocking up the DPF which can cause further issues. it sounds like the fuel additive needs refilling and resetting. shouldnt take more than an hour to do.
Many thank's for the advice,I visited the garage on Saturday to speak to them,they did a re gen which cleared the
relevent code as I had issues with the management light coming on a few times last year but they're in the process
of fitting a new egr but another week has passed so we are two week's into a repair which I'm told should only take a
day once the part arrives they had it Saturday as I was shown it dreading the bill!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Get's Better! finally got the car back on Thursday drove to work Friday have to say like a new car
the engine is responsive and smooth and you can feel the kick when you hit the powerband then
on a trip out today bang hit a pot hole two late to see and recognised the rattle of the rear suspension
bracket at the top which is a common Focus issue I've had on my previous two,jumped back in and
started her up back comes on the malfunction light again!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
hi folk's well nearly sorted after days of both the malfunction light and amber engine light going on and off
dropped it into my preferred garage and told them to see what can be done,the garage that fitted the new egr
fitted the gasket wrong only one hole had the bolt through and the gasket was half blocking the the hole hence
the fault lights fiasco I've took a hit on the £250 original job and had a new egr fitted I'll fight the garage for some
money back for the bodged fitting.still got a flat spot at 1800 rpm which was present after the original egr fitted but
the car is drivable till after the weekend might be a blocked injector or dodgy plug?
 
1 - 7 of 7 Posts
Top