Ford C-Max Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Afternoon all,
I have a ford c-max 2008 1.8 tdci 128000 miles on the clock.
Broke down last weekend, was driving down the m3 on way home, doing about 60-70 mph, put my foot sharply down on the accelerator and the car cut out, pulled up on the hard shoulder and tried to start it again, it would crank but would not start, fault on dash was saying power steering malfunction, called breakdown, he turned up did all the usual checks, but couldn't get my car to start, saying it was the starter motor or alternator, he was a bit confused, so got towed home.
Brought a new battery 2 months ago, so it's not that, had new glow plugs in December.

Brought a starter motor and fitted it, but still won't start, now i have checked all fuses and all sensors and had a spare maf sensor so changed that, but still no joy starting and also the power steering malfunction that was displayed on dash when I broke down has now disappeared
I am completely baffled now
Can anyone help?
 

·
Registered
Joined
·
459 Posts
Sorry to be the bearer of bad news but I'm almost sure your lower wet belt has snapped, you have two belts on your car a top normal belt and a lower wet belt so called as it's constantly in oil this belt often gets forgotten as it used to be a chain and rarely gave any problems. i think from memory the wet belt should be changed at 112,000 but has been known to snap at around 80,000.
 
1 - 2 of 2 Posts
Top