Ford C-Max Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Hi, new here and looking for some help / advice please.

I have a 2007 (57) Ford C-MAX 1.6tdci with 120,000 miles which has recently been showing the message "engine system fault" on the small screen where the mileage is displayed. The EML is not on. When this message is displayed the car also seems to go into limp mode or some sort of reduced speed mode, no power. The fault is intermittent although it is on more than its off. I can sometimes get the light to stay off by putting my foot on the accelerator as I start the car so that it starts up at around 1,000rpm.

I have had the car plugged in at 2 garages and with my own OBDII reader and no codes have been found during any of these scans.

A bit of research pointed to a dodgy throttle position sensor, but the cars with that fault had thrown up a code or two. I also read that it could be a clogged fuel filter which has now been renewed during a full service that I had earlier this week but the fault is still there. I also read that a knackered battery might cause the fault so I had my battery tested at ATS and they said it's fine.

The EGR was renewed about 30,000 miles ago and was cleaned a few weeks ago so I wouldn't have thought that would be the problem.

Also it is worth mentioning that I have been told that the car does not have a DPF, as naturally a lot of these type of faults point in that direction.

So I'm not sure where to go from here. Any garage I speak to claims "it has to be plugged in" but I imagine I'll just be paying for nothing again as there appears to be no codes.

Anyone had a similar problem that they managed to resolve? Or any advice on what to do next? Much appreciated.
 

·
Registered
Joined
·
352 Posts
Just maybe its worth trying a fuel additive to clean the system. I have read many good reports of them but no experience myself. But might be worth trying as its relatively cheap.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #3 ·
Thanks for the reply Gerald. I forgot to mention in my original post that I had ATS put a fuel treatment in. "Techron" I believe it is called
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #4 ·
Just to add to this... I noticed that the battery has never been changed on the car since new (around 8 years)

Is it possible / likely that this could cause the 'Engine System Fault' message and limp mode? I'm thinking this could be related to the fact that when I rev on start up the light stays off

I've never had a flat battery and the car always starts first time, but at 8 years the battery is definitely due
 

·
Registered
Joined
·
106 Posts
Yes, it is quite possible that an elderly battery is causing issues. It may not provide stable voltage despite being able to hold charge. As modern batteries have a habit of dying suddenly without warning, it may be prudent to change it to prevent being stranded one day, unexpectedly. As an example, about 4 years ago my younger daughter bought a 1-owner 7-year old Fiesta that was on its original battery. The garage had difficulty starting the car when we went to test-drive it, but before she picked it up they had fully charged it. After a year or so we then also had occasional difficulties starting the car until one day, daughter went out shopping in it and the car refused to start when she wanted to come home. RAC attended and said battery had packed up, fitted new one at some cost..... and to date, we've not had any starting issues or electrical gremlins since the new battery was fitted.
 

·
Registered
Joined
·
1,237 Posts
was having similar problems jump start the car few days flat battery so replaced with new one from local Halfords happy days 5 year guarantee if any problems in that time frame take it back and they will replace
 

·
Registered
Joined
·
96 Posts
A friend of ours is a farmer and one of the tractors was sat in the yard running at tickover. Everything was running fine but the electronic dash was reading 96mph!!!

Replaced the battery and everything was back to normal.

Goes to show that the battery can cause all sorts of weird faults when they're on their way out.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #8 ·
Thanks guys! Had the battery replaced today with a Yuasa silver calcium battery. The fault is still there but I'm hoping the car just needs time to adjust or something. Meanwhile I am currently cleaning my MAF sensor again (to be sure) as it seems to give unusual readings. It reads 144 g/s when the ignition is on but engine is off, normal?
 

·
Registered
Joined
·
1,237 Posts
Thanks guys! Had the battery replaced today with a Yuasa silver calcium battery. The fault is still there but I'm hoping the car just needs time to adjust or something. Meanwhile I am currently cleaning my MAF sensor again (to be sure) as it seems to give unusual readings. It reads 144 g/s when the ignition is on but engine is off, normal?
that's the make I bought to replace mine
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #10 ·
Good choice! lol. Did you find that the black bracket that fit over the old battery doesn't fit anymore? The new battery is slightly taller
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #12 ·
Just a quick update, mainly for anyone else who might face a similar problem in the future.... All 4 glow plugs were faulty/past it. Had them replaced today and the fault is gone.

To help a bit further, in my research I discovered a post on here about the glow plugs in the 1.6tdci. Apparently they don't work like normal glow plugs I.e for a short time to help with starting, instead they become active during a driving cycle to help with emissions by burning off gasses from the EGR valve.

Hope this helps someone one day
 

·
Registered
Joined
·
1 Posts
I have a similar issue with my 2008 C-max, I was driving to Italy and whilst driving the car started beeping showing the engine failure message acceleration reduced.

I turned the car off after stopping on the side of the road, after restarting the car ran normally again.

Anyone have any ideas what might be happening?
 
1 - 13 of 13 Posts
Top